Yorkton to North Battleford + more!

This post is clearly rather belated.  I finally had internet (and cable!) installed in my apartment today and had been too lazy to write a post elsewhere.

The morning I left Yorkton it was quite cold (-30) and I hadn’t gotten around to having the broken plug for my block heater replaced so starting my car was a bit difficult but I did manage to get it started.  I drove from Yorkton to North Battleford with just one break to use the washroom.  The visibility on the drive was quite good except when I got behind some kind of some removal vehicle on the side of the road that I couldn’t pass for like twenty minutes but I could literally see nothing if I got remotely close to it!  I really think that the section between Saskatoon and North Battleford is one of the best as it isn’t too busy but has two lanes each way so passing is pretty easy.

I started working on February 1 and so far it has been going pretty well.  I have enough furniture in my apartment that I’m okay though there are still a few things I should buy.  So, in general, things have been going quite well!

About these ads

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 206 other followers

%d bloggers like this: